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Module 5: Creating Custom Made Blocks
(My Blocks)

Module Objectives

Upon successful completion of this module, students should be able to:

* Create, edit and configure a my block

* Insert a my block inside a program and test its functionality
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5.1 Introduction

By now you may have noticed that an NXT-G program can quickly become
very large. Furthermore, simple tasks such as displaying a humber or adding
one to a variable can require several blocks. Also, many of the same groups
of blocks are used repeatedly in different programs and often within the
same program. My Blocks help you overcome these issues. Figure 5.1

shows an example of using my blocks inside an NXT-G code.
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Figure 5.1: Using My Blocks inside a Maze Navigator Program

So, what is my block?

A My Block is a collection of NXT-G blocks that you have grouped together

and may wish to reuse.

In this module, you'll learn how to create and use a My Block in your

programs.
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5.2 Lab Activity 1
Objectives:

1. Create, edit and insert a my block into a program
Material per Group:

1. 1 NXT Bricks
2. 1 USB cable

Procedure:
Step 1: Creating a my block

1. Write the following NXT-G code:

2. Download and run your program.

3. What does the program do:

4. Select the sequence of blocks that will make up the My Block by

dragging a selection rectangle over them.

5. Click the “Create My Block” button on the toolbar as shown below:
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6. The My Block Builder window will appear:
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The My Block Builder window contains boxes for entering a name and
description for the new block. The Selected Blocks area lets you see
which blocks were selected to make sure you're creating the block you
expect. If the correct blocks aren’t displayed, click the Cancel button and

start again.

7. Enter BeepBeep in the Block Name box
8. Insert comments to describe your block in the block description
box.

9. Click the next button. The following window will appear:
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10. Create a new icon by dragging one or more icons from the lower

section of the window into the box in the Icon Builder section. You

can resize and move the individual images to create a new unique

icon for your block.

11. Click the Finish button. Clicking Finish will create the BeepBeep

block and replace the old three blocks with the new block in the

program.
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12. Move the blocks closer together
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13. Download and run your program after creating BeepBeep block.

What does the program do:

Question:

What is the effect of creating BeepBeep Block on the sequence of

the program?

Step 2: Viewing and Editing the Contents of a My Block
To edit a My Block, you can either double-click it or select it and choose
Edit>Edit Selected My Block from the menu.

This will open the block in the MINDSTORMS software, where it will look
like a small program. Now, to edit the BeepBeep block, follow these
steps:

1. Select BeepBeep Block
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2. Select Edit>Edit Selected My Block from the menu
3. The blocks that make up the BeepBeep block should look as follow:

=

4. Once the block is open, you can make changes, including adding
and removing blocks, changing the settings of the blocks, or adding
comments. Change the wait block time to 0.5 seconds.

5. Save and close the BeepBeep block (go to File> Save and File>
Close)

6. Download and run your program. What do you observe?

Step 3: Inserting a my block into a program
Once you've created a My Block, you can use it in any program, just like
any other block. All of your My Blocks will appear on the Custom Palette.

1. Select the Custom Palette as shown below:
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Custom palette

2. Insert BeepBeep block into your program. Newly created My Blocks

will appear in the top group on the Custom Palette, as shown
below:
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3. Your modified program will look as follows:
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5.4 Lab Activity 2

Objectives:

* Build a My Block for displaying numbers on the NXT's screen
Material per Group:

e 1 NXT
e 1 USB cable

* 1 Sound sensor
Background Information:

Several of the programs presented in the previous modules have used the
Number to Text, Text, and Display blocks to display a labeled value. For

example, light meter, sound meter and pinball machine programs. Figure
5.2 shows the sound meter program where the sound sensor readings are

collected and displayed on the NXT Screen.

Figure 5.2 The Sound Meter Program

In this activity, you'll create the DisplayNumber block from the Number to
Text, Text, and Display blocks, which will make displaying numbers much

more convenient.

Before creating a My Block, think about the configuration items that your
new block will need. For Example, DisplayNumber block will need the

following configuration:
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» The number passed to the Number to Text block - the displayed
value

» The A value for the Text block-> the label for the value.

» The C value for the Text block-> the unit of the value.

» The Clear setting for the Display block.

Procedure:
Step 1: Setting the configuration of the DisplayNumber block

1. Create a new program named DisplayBlockBuilder.
2. Add a Number to Text block, a Text block, and a Display block.

3. Set the Display block’s Action setting to Text.

4. Open the data hubs of the Text and Display blocks.

5. Connect the Number to Text block’s Text data plug tothe Text block’s
B data plug.

6. Connect the Text block’s Combined Text data plug to the Display
block’s Text data plug.
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7.

Add a Math block at the beginning of the program, to the left of the

Number to Text block.

. Connect the Math block’s Result data plug to the Number to Text

block’s Number data plug.
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Note: The only reason the Math block is there is to connect a data
wire to the Number to Text block’s Number data plug. The Math
block won’t become part of the DisplayNumber block. A Math block
is used because we need to connect a data wire to the Number to
Text block’s input data plug, and the Math block has an output data
plug that uses a number. Any block that has an output data plug

that uses a number would work just as well as a Math block.

. Add two Text blocks at the beginning of the program
10.

Connect the Combined Text data plug of one of the new Text blocks

to the original Text block’s A data plug.

12
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11. Connect the Combined Text data plug of the other new Text block

to the original Text block’s C data plug.
12. Close the data hubs for the two new Text blocks and the Math

block. The program should look like this:
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13. Add a Compare block at the beginning of the program.

14. Connect the Compare block’s Result data plug to the Display block’s
Clear data plug.

15. Close the Compare block’s data hub. The program should look like
this:
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convert number
Thel Label The dsplayed value  totext

Step 2: Testing

All the blocks are now in place and connected. But how do you know it's
really going to work? The only way to find out is to test the code, and the
earlier you test it, the easier it will be to fix any problems. To test the code,
you can set the four input values and then see whether the correct text is

displayed.

1. Add a Wait block to the end of the program.
2. Select NXT Buttons from the list of sensors.

3. Your new program will look as follow:

convert rumber  Add label Display the lzbeled
Thel Label The dsplayed value  totext and unit vl

4. Select the first Text block. Set the A value to Unit, with a space

14 Module 5: Creating Custom Made Blocks (My Blocks)



ATE 1122 - Robotics |l

before the U.

5. Select the second Text block. Set the A value to Label: ,with a

space after the colon.

6. Select the Math block. Set the A value to 17.

7. Download and run your program. What is the text displayed on the

NXT Screen?

Note: If the program doesn’t work, check all the data wire connections;

there are a lot of them, and it's easy to get one wrong.

Step 3: Creating the DisplayNumber Block

Once you have tested your block; it's time to create the My Block. Follow

these steps to create the DisplayNumber block:

1. Select the Text, number to text and the display block.
2. Click the “Create My Block” button on the toolbar. The My Block

Builder Window will appear:
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3. Enter DisplayNumber for the Block Name option.

4. Enter Display a number with a label and unit for the Block

Description option.

5. Click the Next button. The My Block Builder window should now

show the controls for building an icon for the new block.
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6. Create an icon for the new block.

My Block
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7. Click the Finish button. The blocks that were selected should be
replaced by a DisplayNumber block

The Clear Setting The Uni Thel Label The dsplayed value

d

Step 4: Changing the names of the configuration items

The Configuration Panel for the new DisplayNumber block is shown
below:

As you can see, the names for most of the configuration items are not
very meaningful. For example, the block uses two texts: the label and

the unit. The configuration Panel has boxes to enter two texts, but the
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names A and C don't tell you which value each box is used for.
To fix this problem, open the block, and change the names to something
more meaningful by following these steps:

1. Double-click the DisplayNumber block to open it.

2. Double-click the comment with the text A, and change it to Label.

3. Double-click the comment with the text C, and change it to Unit.

4. Save and close the DisplayNumber block.
5. To see the updated Configuration Panel, add the DisplayNumber
block to a new program. The DisplayNumber block should appear

on the Custom Palette. The new configuration will be as follow:

//3 Clear J
7 Label ‘|
5 —
3 Number ‘—0|;;

Step 5: Using the DisplayNumber block inside your program
let’s put it to use. Follow these steps to use the DisplayNumber block in

the sound meter program.
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1. Write the sound meter program

2. Delete the Number to Text, Text, and Display blocks from the

sound meter program

3. Add the DisplayNumber block from the custom palette after the
sound sensor block.

4. In the DisplayNumber block’s Configuration Panel, set the Label
item to Sound: (with a space after the colon).

5. Check the Clear option.

6. Draw a data wire between the sound level data plug to the number
data plug of the DisplayNumber block.

7. Download and run your program. What do you see on the NXT
Screen?
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5.4 Review Exercise

1. Create a "my block” that will convert the rotation of a motor into a
distance. The configuration of the created block will be as follow
» Block Name: R2D
» The block will have one input (the rotation of the motor)

» The block will display the distance on NXT Screen

Hint: distance = circumference of the wheel X rotations

Write your program here:

2. Mention the advantages of using a My Block inside your programs?

References:
. Terry Griffin (2010). The Art of LEGO MINDSTORMS NXT -G
Programming. No starch press: USA
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