
HANDS-ON EXERCIS

1 Form Basics

I HOE1 Training

It is your first day on the job at Santiago Coffee Shop. After talking with Alex about his data entry needs, you decide to create
several sample forms with different formats. You will show each form to Alex to get his feedback and see if he has a preference.
Remember to select the correct record source prior to creating each new form.

Skills covered: Use the Form Tool and Adjust Column Widths in a Form • Create a Split Form • Create a Multiple Items Form «
Create a Datasheet Form and Delete a Field from a Form • Add a Field to a Form • Change the Sorting in a Form and Remove
Sorting in a Form

STEP1 USE THE FORM TOOL AND ADJUST COLUMN WIDTHS IN A FORM
Use the Form tool to create an Access form to help Alex manage his customers. This form will enable
Tonya to add, edit, and delete records more efficiently than working with tables. Refer to Figure 4.7
as you complete Step 1.
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a. Open a04hl coffee. Click the File tab, click Save Database As, and then type a04hlcoffee_
LastnameFirstname. Click Save.

,
TROUBLESHOOTING: Throughout the remainder of this chapter and textbook, click Enable

I Content whenever you are working with student files.
X^ ..-̂ n.Tĵ -,.-. —'

,

TROUBLESHOOTING: If you make any major mistakes in this exercise, you can close the file,
I repeat step a above, and then start over.

b. Click the Customers table in the Navigation Pane. Click the Create tab, and then click
Form in the Forms group.

Access creates a new form with two record sources—Customers (with stacked layout, on
top) and Orders (with tabular layout, below). Access found a one-to-many relationship
between the Customers and Orders tables. The form opens in Layout view.
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C. Click the top text box containing C0001. The text box is outlined with an orange border.
Move the mouse to the right edge of the orange border until the mouse pointer changes to a
double-headed arrow. Drag the right edge to the left until the text box is approximately 50%
of its original size.

All the text boxes and the sub form at the bottom adjust in size when you adjust the top text
box. This is a characteristic of Layout view—enabling you to easily modify all controls at once.

[ TROUBLESHOOTING: You may need to maximize the Access window, or close the Navigation
1 Pane, if the right edge of the text box is not visible.

d. Click the Arrange tab, and then click Select Layout in the Rows & Columns group.

All the controls are now selected.

C TROUBLESHOOTING: Click any control in the top part of the form before you click Select layout.

e. On the Arrange tab, click Control Padding in the Position group. Select Narrow from the
list of choices.

The space between the controls is reduced.

f . Click Save in the Quick Access Toolbar, and then type Customer Information as the form
name in the Save As dialog box. Click OK.

g. Click the Home tab, and then click View in the Views group to switch to Form view, the
view that most users will see. Advance to the sixth customer, Lugo Computer Sales, using the
Navigation bar at the bottom of the form.

| TROUBLESHOOTING: Two Navigation bars exist, one for the main form and one for the
{ subform. Make sure you use the bottom one that shows 14 records.

h. Double-click the Customers table in the Navigation Pane.

Two tabs now appear in the main window. You will compare the table data and the form
data while you make changes to both.

i. Verify the sixth record of the Customers table is Lugo Computer Sales, which corresponds
to the sixth record in the Customer Information form. Click the tabs to switch between the
table and the form.

j. Click the Customer Information tab, and then replace Derek Anderson, the contact for
Lugo Computer Sales, with your name. Advance to the next record to save the changes.
Click the Customers tab to see that the contact name changed in the table as well.

The contact field and the other fields on the Customer Information form are bound controls.
Changing the data in the form automatically changes the data in the underlying table.

-
TROUBLESHOOTING: If the change to Derek Anderson does not appear in the Customers table,
check the Customer Information form to see if the pencil appears in the left margin. If it does, save
the record by advancing to the next customer, and then recheck to see if the name has changed.

k. Replace your name with Derek Anderson. Save the record by clicking on the record below
Lugo Computer Sales. Click the Customer Information tab, and then find the sixth record.
You should see the change you just made — Derek is back!

I. Switch to Layout view. Click the Customers title at the top of the form to select it, and then
click again and change the title to Customer Information.

The Customer Information title, a label control, is an example of an unbound control; an
unbound control does not have a connection to an underlying table.
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m. Click Save in the Quick Access Toolbar to save the changes to the form's title. Close the
form and the table.

| TROUBLESHOOTING: If you make a mistake that you cannot easily recover from, consider
I deleting the form and starting over. The Form tool makes it easy to start over again.

STEP 2 CREATE A SPLIT FORM
Use the Split Form tool to create a different form to show to Tonya. She may prefer to use a split
form to add, edit, and delete records rather than the Customer Information form that you created in
the previous step. Refer to Figure 4.8 as you complete Step 2.
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(Change the e-mail address

f Splitter bar

[ Changes in the top section
I are reflected in the bottom

FIGURE 4.8 Form Created
with the Split Form Tool >•
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C0007 Bethune Appliance Sales Michael Ware
C0008 Baker Auto Supply Robert Slane
C0009 Howard Animal Hospital LuisCouto

1 Record: M 4 6 of 14 > H > Search lil—

~| State FPA

j Zip Code [ 18976-

| Phone | (215) 446-8900
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9020 N.W. 75 Street

ageoghejgan@milgrom.net 7500 Center Lane
keith@lugocomputer.net 6000 Tigertail Avenue
bethune@bethune.com 276 Brickell Avenue
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a. Verify the Customers table is selected in the Navigation Pane. Click the Create tab, click
More Forms in the Forms group, and then select Split Form from the list.

Access creates a new form with a split view, one view in stacked layout and one view in
tabular layout.

b. Switch to Form view. In the bottom portion of the split form, click Lugo Computer Sales, the
sixth record. Notice the top portion now displays the information for Lugo Computer Sales.

C. Change service@lugocomputer.net to yourname@lugocomputer.net in the top portion of
the form.

The bottom portion reflects your change when you move to another field or advance to
another record.

d. Click another record, and then click back on Lugo Computer Sales.

The pencil disappears from the record selector box and the changes are saved to the table.

e. Click anywhere on the Coulter Office Supplies customer in the bottom portion of the form
(record 14).

The top portion shows all the information for this customer.
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r f. Modify the Contact, E-mail Address, and Address 1 information in the top portion of the
form, by typing xyz at the end of each cell. Save your changes by clicking anywhere in the
bottom portion of the window.

Notice the xyz characters appear in the bottom portion of the form.

g. Remove the xyz's from the Coulter Office Supplies record in the top section.

h. Switch to Layout view. Click the Customers title at the top of the form to select it, and then
click Customers again and change the title to Customers - Split View.

i. Click Save on the Quick Access Toolbar, and then type Customers - Split View in the Form
Name box. Click OK.

j. Move your mouse over the splitter bar, the border between the top and bottom portions of
the window. When the pointer shape changes to a double-headed arrow, drag the splitter
bar up until it almost touches the Sales Rep ID field.

k. Close the form and save the changes when prompted.

STEP 3 CREATE A MULTIPLE ITEMS FORM
You decide to use the Multiple Items tool to create a form for Alex to manage his products. Because
of its tabular format, it will enable Alex and Tonya to view multiple records at one time. Refer to
Figure 4.9 as you complete Step 3.
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a. Click the Products table in the Navigation Pane. Click the Create tab, click More Forms in
the Forms group, and then select Multiple Items from the list.

Access creates a new multiple items form based on the Products table. The form resembles
the datasheet of a table—both have a tabular layout.

b. Click cell POOOl. Move the mouse over the bottom edge of cell POOOl until the pointer
shape changes to a two-headed arrow. Drag the bottom edge up to reduce the height of the
rows by 50%.

Changing the height of one row affects the height of all the rows.

C. Click the Products title at the top of the form to select it, and then click again on Products
and change the title to Products - Multiple Items.
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STEP 4

d. Click the Themes arrow in the Themes group on the Design tab. Right-click the Technic
Theme (near the bottom of the gallery), and then choose Apply Theme to This Object
Only.

Hover over a theme and its name will display as a ScreenTip. The Technic theme is applied
to the Products - Multiple Items form.

e. Close and save the form as Products - Multiple Items.

CREATE A DATASHEET FORM AND DELETE A FIELD FROM A FORM
You decide to use the Datasheet tool to create another form for Alex to manage his products. The
Datasheet form is in tabular format and is similar to the Multiple Items form, but requires little or no
maintenance, which Alex may like. Refer to Figure 4.10 as you complete Step 4.

Datasheet form based
on the Products table

-

Field name modified

Datasheet form looks
similar to Datasheet view

FIGURE 4.10 Datasheet
Form >•
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Coffee - Colombian Supreme
Coffee- Hazelnut
Coffee - Mild Blend
Coffee - Assorted Flavors
Coffee - Decaf
Tea Bags - Regular
Tea Bags - Decaf
Creamers - Assorted Flavors
Creamers- Liquid
Sugar Packets
Ceramic Mug

Sugar Substitute
Coffee Filters
Napkins
Stirrers - Plastic
Stirrers-Wood
Spoons
Popcorn - Plain
Popcorn - Buttered
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Soup - Variety Pak
Styrofoam Cups - 10 ounce

Styrofoam Cups - 12 ounce
Milk- 1 quart
Milk- Ipint
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24/Case, Pre-Ground 1.7S Oz Bags
24/Case, Pre-Ground 1.75 Oz Bags
24/Case, Pre-Ground 1.75 Oz Bags
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24/Case, Pre-Ground 1.75 Oz Bags
75/Box, Individual Tea Bags
75/Box, Individual Tea Bags
400/Case, 8 50-count Boxes
200/Case, Individual Creamers
2000/Case
SD Company Logo
500/Case, 1- Serving Bags
500/Case, Fits 10-12 Cup Coffee Maker
3000/Case, White
1000/Box
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36/Case, 3.75 Oz Microwave Bags
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Delivered Daily

sfrig? *• Brand

Discount

13 Premium
n House

d House
D Discount
D House

House
D Discount
13 Premium
D House

CH House
n Discount
D House

d House
d Discount
D Discount
d House

EJ House
Ci House
[U Premium
E3 Premium

House
d House
El House

El House
CI House

X

- Year Introduce

2008

2008

2008

2008

2008

2008

2008

2008

2008

2008

2008

2008

2008

2008

2008

2008

2008

2008

2008

2008

2008

2008

2008

2008

2008

2010

a. Verify the Products table is selected in the Navigation Pane. Click the Create tab, click
More Forms in the Forms group, and then select Datasheet.

Access creates a new datasheet form based on the Products table. The Tabular form looks
similar to the Products table and could be easily mistaken for a table.

b. Click Save in the Quick Access Toolbar, and then type Products - Datasheet in the Form
Name box. Click OK.

C. Widen the Navigation Pane so all object names are visible. Right-click the Products -
Datasheet form in the Navigation Pane, and then choose Layout View from the list of options.

TROUBLESHOOTING: The View arrow does not contain the Layout view options.

d. Click anywhere in an empty area to deselect the controls.

e. Click the Cost box, the control on the right, to select it (you will see the orange border), and
then press Delete. Click the blank space, and then press Delete to remove the blank space.
Repeat the process to delete MarkupPercent.

You removed fields from the Products form and the other fields adjust to maintain an even
distribution (after you remove the blank space).
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f. Click the Refrigeration Needed label to select it. Change the label to the abbreviation
Refrig?. Save the form, and then switch to Datasheet view.

g. Double-click the Products table in the Navigation Pane to open it.

The Products - Datasheet form and the Products table now appear different because the
Cost and MarkupPercent fields were deleted from the form.

h. Close the Products Datasheet form and the Products table.

r
STEPS ADD A FIELD TO A FORM

The form tools made it easy to create forms for Alex's company. But Alex decided he needs a
Website field, so you need to modify the form. Refer to Figure 4.11 as you complete Step 5.
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Website field added
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| Orange line indicates the
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a. Right-click the Customers table in the Navigation Pane, and then click Design View.

You will add the Website field to the Customers table.

b. Click the Addressl field, and then click Insert Rows in the Tools group.

A new row is inserted above the Addressl field.

C. Type Website in the blank Field Name box, and then choose Hyperlink as the Data Type.

d. Close and save the Customers table.

6. Right-click the Customer Information form in the Navigation Pane, and then click
Layout View.

You will add the Website field to the Customer Information form.

f. Click Add Existing Fields in the Tools group to display the Field List pane (if necessary).

g. Drag the Website field from the Field List pane to the form, below the E-mail Address field,
until an orange line displays between E-mail Address and Addressl and release the mouse.

Access shows an orange line to help you place the field in the correct location.

Hands-On Exercises • Access 2O1O



STEP 6

h. Switch to Form view. Press Tab until you reach the Website field, and then type www.
microsoft.com into the field.

j. Press Tab until the focus reaches the Orders sub form to verify the tab order is correct.

j. Close and save the Customer Information form.

CHANGE THE SORTING IN A FORM AND REMOVE SORTING IN A FORM
Alex tested the Customer Information form and likes the way it is working. He asks you to change the
sorting to make it easier to find customers with a similar Customer Name. Refer to Figure 4.12 as you
complete Step 6.

f Click Ascending to sort
by customer name

fSelect customer name

Advance to the next record
to verify sort order

FIGURE 4.12 Datasheet
Form >
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J Customer Information

Forms
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Products. Datasheet

Products - Multiple Re

5000 Jefferson une

Suite 2000
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Credit Rating

Sales Rep ID
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1/21/2012 Credit Card

a. Open the Customer Information form. Click Next record in the Navigation bar at the
bottom several times to advance through the records.

Take note that the customers are in Customer ID order.

b. Click First record in the Navigation bar to return to customer Abel & Young.

C. Click the Customer Name field, and then click Ascending in the Sort & Filter group.

d. Click Next record in the Navigation bar at the bottom to advance through the records.

The records are now in Customer Name order.

6. Close the Customer Information form.

f. Click the File tab, and then click Compact & Repair Database.

g. Keep the database onscreen if you plan to continue with Hands-On Exercise 2. If not, close
the database and exit Access.
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