Upgrade of Java Quiz: Knowing your Vocabulary,current affairs and Singapore's actors news.

Hey,pals,knowing your vocabulary is important in this secondary time and current affairs around the world. But learning all these will stress you up and so I've included some gossipping news. So this is the time to show off your talents. But, you need a Java based browser to see it. Minimum requirements:
I.E 4 or Netscape Composer 4.5 or professional edition. So just have fun!!!




This activity was created by a Quia Web subscriber.
Learn more about Quia
Create your own activities